Standalone Silhouette not interpreting mocha surface correctly

Hi folks,
I’ve just jumped from sil AE plug to standalone.
This morning I did a screen insert (mocha pro node to transform in SIL) , all went well.
I was asked to make a small adjustment, and the surface is now misaligned… looks smaller.
I tracked it again, all looks fine in mocha, but misaligned when I jump out to Silhouette.

To troubleshoot, I made a new project, tracked again, and this behavior persists.
Any ideas what this problem is (both shot and insert are HD 1080)

thanks,
Peter

1



A couple of things:

  • The Mocha surface is used within the Transform node when set to Insert, but the surface is not editable there.
  • The point controls that you see in the Transform node in the corners of the image are the Corner-Point controls of the Transform node and don’t do anything when set to Insert since they are automatically being set to the Mocha surface.
  • To change the Mocha surface, you need to go back into the Mocha node user interface.
  • The better way to do this is to create a Roto node from the Mocha Pro node in the Node Options menu.
  • Then plug the new Roto node into the Transform node. When you want to make adjustments to the surface, you would adjust the Layer > Surface in the Roto node.

I understand your first three points.
I attempted to do what you said, and it is way worse.
What I find weird is it worked this morning, i used the setup Ben Brownlee showed in the promo vid.
It worked… now it doesn’t ??

Pics of my failure below


Why does the Silhouette surface not match the mocha pro surface?
This is my problem… the rest I can probably figure out.
thanks
P

The surface from Mocha Pro does transfer from the Mocha Pro node through the data port, but you can’t adjust it in Silhouette. This is why I am suggesting that you create a Roto node from the Mocha Pro node using the Node Options. When you do this, not only does the Mocha Pro surface come across, but it can be edited. To edit the Layer > Surface, you need to select the Layer first and then edit the surface controls in the Object window.

OK… this is not working… i did your steps

if I input “0.27” it’s close
“0.28” is too far
“0.275” cannot be entered because it wont accept the other digit.
If I use the + widget next to it the motion is too coarse and I can’t
accurately adjust the corners.

I appreciate your help,
BUT… this seems like an elaborate and insufficient workaround to try to make up for the fact that the basic functionality is not there.

-I am not trying to edit the surface in Silhouette, I never said I was.
-I am editing the surface in Mocha and trying to pass the corner pin surface to Silhouette.

this is the basic functionality of the software.
Do a track and assign a surface in mocha… jump out to the host and carry on.
It’s not working.

Please answer the question:
why is the surface established in Mocha not being passed accurately on to Silhouette?

thanks for you time,
p

Maybe I’ve discovered a bug.

pic a… superfluous nodes… bad surface placement.
pic b… delete these nodes and open and save mocha… problem solved…???

I don’t get it… those nodes are not on the chain to affect anything… just side branches.


This doesnt really explain why it was broken on the simplified node tree i showed at first though.

To clarify, the Mocha Pro surface does come across to Silhouette through the data port.

I see that you had a Crop in the Trees window and if you adjusted that and fed that into Mocha Pro at one point, that could explain the issue you were seeing. The Crop changes the resolution and this could have confused Mocha.

Doesn’t like a rack focus… :upside_down_face:
adjusting a node downstream shouldn’t affect the comp layout?


Somehow a resize with nothing adjusted fixes it. :thinking:
Hard to understand this, eventually i’ll figure out what hexes and talismans I need to get predictable results.