Straight edge showing instead of curve

Greetings,

I’m getting a straight edge showing up on a curved portion of an x-spline in v2020.5.7. The straight edges are visible when I set the View to Color Comp or view the Alpha and zoom in to around 200%. It looks like it’s just some type of curve precision setting, so is there a way I can adjust this or is there something else I need to do? Thanks for the help!

Can you send some screen shots?

Hi Marco,

Here’s a sample showing where the blue alpha shows as a straight edges instead of a curve like the x-spline. For reference, my settings are all set to default values and the edge blur set to 0 (screenshot 1).

I’m used to seeing this happen when working in 3D programs where I need to bump up my polygon precision setting for curves, but not sure what to do here other than adding more curve points, which seems to smooth out the blue alpha closer to the actual curve, or just make sure to “grow” my x-spline to cover what I’m trying to roto, but even when growing and blurring. the blue alpha edge still shows as a straight edge (screenshot 2). Please let me know if you need more info, thanks!


Can you send your project without media so I can take a look?

Hi Marco,
Here’s a sample of frames 1033 to 1146 of showing the situation of the roto node. You can see the straight lines of the alpha in the nose, forehead, and lip areas, amongst other layers. Thanks for looking into it!
alpha curve test.sfx.zip (2.3 MB)

Can you tell me which frame and which shape displays the hard edge?

I see it throughout frames 1033 to 1146 on the right curved tip of Nose layer and other layers too. This is what it looks like on my screen at frame 1033. Thanks.

I can’t duplicate the issue on either Windows or Mac. I am not sure why it would be happening on your machine. What OS/version are you running and what type of graphics card do you have?

Interesting. I’m on High Sierra 10.13.6 with an AMD FirePro D700 6144 MB graphics card.

@persyst I am not sure what the issue is as I can’t reproduce it on my machines. See my previous screen shot.

Darn, I’ll just keep an eye out to make sure it doesn’t effect my final export. Thanks for looking into it Marco!

If you see it when you view alpha, it will most likely render that way. You may want to try and redraw the shapes as B-Splines and see if that makes a difference.

Thanks, might try that. I’m already tracked out on the entire clip which is pretty long. Don’t want to have to go through it again, unless the render result doesn’t look right with the current x-spline.

Maybe just try changing between the point types on your XSpline - say change to a corner and then back again to B-Spline. Who knows, it might refresh whatever math is happening to make those points do that? That one screenshot looks like the lines are being made based on the control points - so perhaps they are being treated as corners or with a very tight curve setting to them.

Also, since the tracking is applied to the Layers Matrix and not the shape itself you can merely hide your XSpline and then redraw the shape with a new B-spline inside the Nose Layer and it should follow the object you tracked just as well as what you have (the extra effort will obviously come with the other hand animations that need to be done when roto-ing something like nose movement).

I also took a look for 5 minutes and downloaded your project file and it made a perfect curve shape along the line for me, so your issue is indeed very strange. I did notice that when I zoom in to 1000% like your first screenshots then I start to see straight lined style stair stepping of aliased shape but I don’t think someone would see anything that is closer than 200% especially once motion blur is applied and matched.