Surface keep running away

Its amazing how even simple things become complicated with Mocha!

So i bought the latest essentials course,
I’m trying to do the first (!!) lesson, doing exactly what Marry is doing there, but, lo and behold, she got immediately perfect match of the surface to the screen plate, while i struggle no matter what I’m doing its keeps (the corners especially the lower ones) slipping away!!

Sorry and all but I’m literally spend my last 2 hours on it trying maybe other methods, but nothing is working and it is driving me crazy!
I cant figure out what am i doing wrong?
Why isn’t it as simple as it shown?!

In your version, it looks like the shape is a little too tall and is capturing the movement of the finger later in the timeline. If you bring that shape edge up a bit to be more in line with the first set of green squares, the shot should track slightly better.

Hey Martin, thank you for replying :slight_smile:
About the finger, here is what Marry is saying on the tutorial:

" Because we take into account how the texture changes over time, the little interruptions like this finger
just quickly moving the surface of our pad, do not interrupt our track, but if the hand stay there it would almost certainly interrupt the track| "

-If you bring that shape edge up a bit to be more in line with the first set of green squares-
Are you talking about the squares with the Play button in it?

Hi there,

Try narrowing the shape like Martin suggests. The finger shouldn’t interrupt, as I say in the tutorial, but maybe the shape is slightly different and it is interrupting. Or it could be the background pulling through as well. We can track outside the edges but sometimes if it’s just a few pixels too big then Mocha thinks that that edge is part of the texture.

It really should be a pretty simple track. And if it isn’t, try taking your percentage of pixels down or try tracking with CPU instead of GPU.

Can you try that and let me know?
Cheers,
Mary

Hey Marry :slight_smile:
Thanks for trying to help, i dont take it for granted.
So, if i did understand you correctly, the first thing i need to do is lowering the line in the white circle:
image

P.S.
where do i change from GPU to CPU?

Happy to help!

Take that line in white down and the lines at immediate right angles to that line in closer to the edge, to about 10-15 pixels outside and no more than that.

You can turn off GPU tracking in the Mocha Preferences, go to file>preferences, and under the GPU tab you should be able to turn GPU tracking off. You will need to save and close and then restart both Mocha Pro and the Host you are running in, like AE or Nuke, etc.

And then try tracking again.

Hell Yeah! that`s worked for me!
I think you were right about Mocha thought that edge, part of the texture due to the gap i gave to the right line from the tablet.
Thank Marry :slight_smile:

Glad that worked!