Titles with Alpha in Resolve and VR Insert

Hi, I’m working in Resolve 16 and just got VR unit and struggle with inserting a title via png with alpha over a 360 stereo clip. If I apply the effect to the background node/clip I get white boxes on each eye instead of a transparent title. If I do as the manual suggests (continuum 11.0.3 and higher), I should apply the effect directly to the insert layer, which is my png file/node - and as an ext. matte this node can’t carry an effect. So I’m stuck here. Please help me out. Just need to know how to get titles with alpha (png) displayed correctly in Resolve 16 and VR Insert.
Thanks!!

Hi There,

You might get a better understanding of how to use the BCC VR filters in Resolve by watching this tutorial clip : Boris FX | Continuum VR Unit for Resolve - VR Reorient & VR Insert

I hope this helps!

Cheers,
Peter.

Hi Peter,
thanks. I know, i´m a noob on this, but I really hope I´m past this intro video already. :wink:
The manual says, I should apply VR Insert to the insert layer - which is an ext. matte in my case and therefore can not carry this effect. If I do the workflow until continuum v11 and apply the effect to my background, I get white boxes. See screenshot.

Hi,

Take a look at the set up I have in this screenshot - are you setting up in the same way? I think you may some inputs crossed.

Thanks Peter! I tried to rebuild your setup. In my case, the background clip disappears (marked green; it´s a 360 stereo clip with BCC Reorient applied to) and turns black and the title (marked red in the screenshot) does not show up on both eyes, infact just gets displayed like flat footage. What am I missing? Could you explain your process to me? If I understand this correctly, in edit tab you put that tiff over your 360 background clip, marked that tiff, switched then to color tab. There you added a serial node to the existing one, added an alpha output, dragged that same tiff into the node area as an ext. matte and connected it with output and alpha to the original node, applied the BCC Insert effect to the serial node on the very right. At least, this is what I could make of your screenshot and got stuck here again. Could you clarify your steps a little for me? Thanks a lot! I just need to put out this clip real soon and my client is getting unpatient, but knows this is something not every video editor can know, but I don´t want to strech his patience too far. Thanks a lot!

Here’s the way I set this up in Resolve :

in the edit tab:

• stack the (insert) image with alpha on v2 and the background clip on v1

in the color tab:

• select the v2 track (the insert)

• add the bcc vr insert filter as a separate node to the graph

• pipe the output of the insert clip to the input of the vr filter node

• pipe the alpha output of the insert clip to the alpha input of the vr filter node

• add alpha out to the graph

• pipe the alpha out of the vr filter to the alpha out on the graph

• right+click the insert clip and select add alpha output

in the OFX filter controls:

• set the insert apply mode to replace

I hope this helps!

Cheers,
Peter.

Hi Peter, thanks for these steps.
I know this seems easy but here is what doesn´t work with the suggested steps:

• right+click the insert clip and select add alpha output

There is no option in the insert clip for adding alpha output. By “insert clip” you mean the other node that is not the BCC Insert node, right? You don´t mean the actual clip/png in that clip row of the color tab? (there would be no option to add alpha output either). So what are you right clicking for adding alpha output?

Another thing that I don´t understand: why does this workflow not require a three node setup anymore (with the ext. matte like on the image you posted earlier)?

I follow you until
• pipe the alpha out of the vr filter to the alpha out on the graph
Then my text (even only shown in 2D Flat) disappears from the screen and I don´t know what you are right clicking to add an alpha output.

This is my setting so far:

Right clicking on the “insert” clip is showing these options:
2

Right clicking the BCC Insert Node is showing these options:

Cheers,
Steffen

Hey Steffen,

In the last image, there is an option to “Add Matte” in the pop-up that appears with the right+click on the Insert Clip node. When you go to that you’ll see an option to use the clicked source as a matte. When you select that Resolve will automatically pull the matte source and connect it to the Insert. I can make a screen recording of the process for you if that might help. I’ll try to make that and upload it for you this afternoon.

Cheers,
Peter.

Hi Peter, I tried that with the matte many times. It results in what brought me to my original post: a flat image on both eyes with white background instead of transparency. (see screenshot at the beginning ot this thread).

Hi Steffan,

One quick question for you before I generate the screen recording … what type of file is the text source? Is it an imported image with alpha or a live source from within the Resolve timeline?

It´s a png with alpha, generated in InDesign.

Here’s a link to a screen recording that just created to better illustrate the process. Please let me know if this helps.

https://drive.google.com/file/d/1uaVIPK0p-5w_kzmwiq59zAFOZMqczMIf/view?usp=sharing

Thank you so much, Peter! Problem solved! My error was a node-issue. You just dragged the BCC Insert effect into the graph, which automatically generated a node. I falsely added another serial node to the insert node and dragged the BCC Insert on that one. I still don´t understand the difference, but this did the job. Thank you very, very much!
Cheers and Greetings from Germany!

You are most welcome Steffan - I’m delighted that you managed to get it working. That Resolve UI can be a tricky one sometimes!

Please don’t hesitate to reach out for assistance should you encounter any difficulty with any of the other Continuum filters.

Greetings from Boston!

Cheers,
Peter.

Thanks for helping out and for the offer!