Track Data bug

I have been tracking parts of a face to create a moph effect. I create the track data, which works fine, but when I “Apply Export” it exports the tracking data from the layer I previously exported. Then it gets hung up and won’t export any tracking data besides the last. I.e. I tracked the nostrils, mouth, and eyes then exported the transform data for the nostril, but now when I create track data for the mouth it will only export the data from the nostril.

It is sometimes fixed by rebooting AE, but it isn’t consistent.

Has anyone else encountered this?

Using Adobe After Effects 18.0.0 on Big Sur 11.2.3 on an 27" 5k iMac 2020.

Do you create new track data every time from the different layers? If so, can you try deleting your Mocha cache and your AE cache and see if that helps?

Yes. I have been creating new tracking data from each layer to export as corner pin with motion blur to effects and masks. I tried deleting both caches and it doesn’t help. Same issues.

I can’t repeat this on my end, let me see if @martinb has seen anything.

Here are screen shots of what I did. The destination layer is the same resolution and frame rate as the tracked footage, with all the default position, scale, rotation, anchor point settings. I’m trying to track a screen, and insert one image onto it at the beginning and a second image onto it at the end.

  1. manually tracked the screen at the beginning and end as two separate layers. For the first shot the data exported correctly and the corner pin insert worked.

In between exporting the corner pin for the first layer, and creating the data for the second I dumped the cache for both AE and Mocha.

  1. created tracking data for the second insert.

  2. set my destination.

  3. exported to layer and the transform and corner pin data remains from the first insert

Is there a step I’m missing?

Thanks for bringing this up Paul. We’ve seen this literally once before and couldn’t reproduce it but i’m glad to see it’s real, even if it’s a pain.

Here’s what I’d like you to try:

  1. Open mocha and export the project from the file menu
  2. Close mocha and delete the plugin
  3. Create a new mocha plugin effect
  4. Open Mocha and open the project you exported

Then try doing the data exports again.

Alternatively, try exporting from “Export track data…” on the track page inside Mocha and copy the Corner Pin data to the clipboard, close the UI and paste.

Hey @paulsmyers did you have any success with this?

Only partially and it is very frustrating.

I have tried the method of exporting the project, deleting the plugin from the layer, then putting the plug in on again, and opening the saved project. It works occasionally, but not always.

I will say for a $250 plugin this is a pretty annoying result. It has slowed down my workflow and built in a huge amount of stress trying to find work arounds to get the plugin to do the very thing it is designed to do.

Can you instruct me on how to fully uninstall this thing? Maybe I can get it to work if I do a clean reinstallation.

Hi Paul,

Are you seeing this problem on every project you try?
If so, we’d like to remote to your machine to see if we can glean more information about the specific issue and why it reproduces with your setup.
We’ve only seen this problem once before on another client machine several months ago so it’s not specific to the plugin as it doesn’t happen on most machines or every time.

Are there any other third-party scripts or plugins you use with After Effects?

You uninstall on Mac by deleting the /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore/BorisFX/MochaPro2021 folder, or by reinstalling over the top with the same installer.