Track data export not applying?

So I am a bit new to mocha and I was watching the tutorial,

  1. So I make a perfect track (Shows up good on mocha, tracking perfectly) Exit out of mocha,
  2. go to video Effects Tab Mocha AE to Create Track Data (Corner pins on mocha are tracking and data is accurate so far),
  3. I go to Layer Export To = Logo I’m trying to get tracked
  4. Logo is crushed into small ball in the corner and not following the corner pins… The logo’s corner pins are now WAY off from what the mocha comp is, and its also static not even tracking the wrong way. The only data exported with “Layer Export To” was the wrong corner pin data.

I have made a precomp for it and adjusted the size using layers/transform/fit to comp but still no dice. Did I miss a step? I pretty much restarted the project and followed 3 youtube videos, it works for them but not for me. Would love some help, thank you.

UPDATE: So I got the corner pin data to position properly, the logo is in the right space but nothing is tracking still except the mocha corner pins those seem to work fine and even mask properly.

Is the logo using its own frame range, or is it a still image?

Can you show a screen grab of your timeline setup?

No both comps are the same, I think the problem is using the “Apply Export” Command is corner pinning the right way but no tracking data is being sent to the target comp, I am using a square logo as an example

After I move it showing the corner pins are tracking but the logo is not

Right, it looks like you have a time stretch on the logo layer as the keys are being spread out.
Can you check the ranges on that layer? Click the {} button in the bottom left of the timeline.

I tried changing them to both 100% but nothing happened.

UPDATE: So I tried the same process I did in a new project and it worked fine… Does that mean this project it bugged maybe?

UPDATE 2: I retried the process from scratch (New file, new everything) Project works now, so strange, I used the exact same methods nothing different… Guess It just did not like the file I made.

If the timestretch happened before Mocha was applied it was probably going to be out of sync in the main project and would have needed retracking. You can always timestretch, precomp and THEN apply Mocha to get the right timing.

Glad you’re back to a functional project!