Track Data only applies to some footage and not others. And question about Precomp workflows

Hello everyone,

I am using Mocha v2022.5.4, on After Effects 2023.
I use the Plug-In effect onto my footage layer, track in Mocha, then use the plug-in window to generate track data from the layer I want (in mocha) and then paste to the layer I want, in this case, text layers.

I have a few general questions about Mocha.
I have an AE project, and within my Comp, I have a series of precomps. My main precomp is 1080x1080 at 23.976 fps. Inside this precomp, I have various other precomps, and those precomps contain clips that vary. Some are 4096x2160 at 24 fps, some are 3840 x 2160 at 29.97 fps. My question is this. There are some sequences where the tracking data applies properly, and others that don’t. Let’s take one example. I have a Precomp that is 3840 x 2160 at 30 fps. Inside this precomp I have two clips, 1 that is my footage, which is also 3840 x 2160 at 30fps, and another Text Precomp, which I have also made to these exact settings–3840x2160 at 30fps. Yet, when I try applying the mocha tracking data, it doesn’t paste any keyframes into the Text layer, or only one keyframe gets copied.
It soemtimes works on certain comps, and one of the workarounds I’ve found is copying and pasting the mocha effect itself onto the Text layer, or text layer precomp, sometimes works.

My questions would be:

  1. Can I have different size precomps (with various fps) throughout my main comp, so long as I keep the precomp and the contents within the same size and frame rate as the comp it’s in?

Just to clarify, are you trying to apply Transform data (i.e. translation, scale, rotation), or Corner Pin data?

In After Effects 2023 Adobe has made some changes to the Position parameter. Now it has Separated X and Y dimensions by default. So, to apply Mocha’s Transform data, you either need to disable “Separated Dimensions” feature, or, update to Mocha 2022.5. Version 9.5.5 where we made that feature supported :slightly_smiling_face: It’s available here Boris FX | Downloads

To answer your question, as long as the precomp you’re pasting data to is matching the resolution & fps of the footage that was tracked, you’re should be good to go. If you could attach the video demonstration of the issue that would be helpful

Hi Elizabeth,

Sorry for the delay.
I actually tried both position and corner pin (And remembered to delete existing tracking data), and it still didn’t work. I will try this with the latest version of Mocha as well.

I am going to try this again, and if the issue persists, I will include a video of what I do.

Actually, your YouTube video helps out a lot with precomping:

Thank you very much for the help!

Were doing our best, to make this tutorials clear and informative!

Right, If the issue persist, the demo video with the issue would work best