Tracked object wrong size and position in AE

Hi! After I track a layer in Mocha for AE 2020, when I apply tracking data to the layer with the object I want to track to the first layer, the size and position of said object are wrong - they have been sized up. How do I preserve the correct scale and position of the object I’m tracking onto the layer I tracked?
THanks!

While the exact workflow is different, you might find this tutorial helpful for using align surface with mismatched resolutions in AE: https://borisfx.com/videos/align-surface-and-mismatched/

However, if you are trying to insert an oversized insert, larger than the comp, you may find the basic megaplate corner pin workflow useful. In Mocha, after tracking to your satisfaction, set your reference frame where your insert lines up by using the “align surface” tool on the matching frame. Save and close Mocha. In AE, for oversized corner pins to line up properly with your AE composition and pass the large frame without losing resolution, you need to pre-comp your insert and you MUST make sure to select “leave all attributes in composition."

Now you can select the new pre-comped composition and toggle on “collapse transformations.” What this does is this allows you to take a really large file and have it adjust the transformations of the layer so that they don’t alter when you add a new transformation over the top like a corner pin. This is how you keep a full res image anti-aliased and prevents over-processing the image and losing image quality.

In the Mocha Pro interface, select the “create transform data” button and select your tracked layer to create the tracking data from. Next, select your preferred export, and select the target layer, and hit apply.

Hope that helps.

1 Like

Thanks - I’m not using corner pin BTW - I’m tracking the collar area of this suit and using that tracking data to make the pepperoni puppet face move along with the suit. When I set up the layers in AE and make the puppet face the right size and position relative to the suit, it then is scaled up when I apply the tracking data to it. (note screen shots are out of order the first one shows the resized result)

Ok. Perfect. Paste the tracking data on a null and pickwhip that extremely disturbing face to it. :wink: You may need some rotation correction to make the bottom sit right.

1 Like

Hi Mary, I’m unable to solve my problem. No matter what I try when I apply the tracking data to the insert layer it jumps to the wrong place. Here are my steps:

  1. Layers in comp as they were shot.
  2. I position the insert layer and precomp, leaving attributes
  3. Track layer I’m inserting to.
    4.Apply tracking data to insert layer

Hi there,

I had suggested making a null, applying your tracking data to that, and then putting the object where you need it and pick-whipping to your null transforms. Have you tried that? You’ll want the center point of your surface tool where the neck is.

I see you applying tracking data to the objects, not a null. Make sure your surface tool is following where you want your transform data exactly.

Can you try that and let me know? Keep in mind your shape is NOT your tracking data, only the surface tool shows you what the track is doing.

Cheers,
Mary

Yes - I did try a null at one point and had no luck. But I’ll try again now.

Also, I want the head to rotate and move positions, but I don’t want the scale or shear enabled - is there a way to do that? The shear and scale tend to add weirdness I don’t want…

BTW Thank you so much for your help!!

Just don’t use shear or perspective when you track. I’d make sure your surface tool was right at the bottom of the neck. So that that’s the actual anchor. You’re still probably going to have to do some puppet tooling or some hand correction to get it to look right. Or you can watch my headless horseman tutorial. Which I probably should have linked beforehand…

Sorry about the audio it was before I got a nice mic. It’s not the exact same workflow but it kind of gives you an idea.

THanks, still struggling. The first movie is me using a null and keeping the anchor point in the middle of the burger bun head, the second movie I moved anchor point to the middle of neck where the anchor point on the blue box surface indicator in Mocha was - I put it right above knot of the red tie. The result was similar to the first one - sci I fixed it by hand with position key frames as shown in screen capture. The sloppy masks and keys are because I’m just trying to test the tracking. Even the hand fixed version doesn’t look great - there’s a fair amount of jiggling. I’ll watch your tutorial …

first video: https://www.dropbox.com/s/73uffmpub3xpews/Pre-comp%203%20BM%20track%20w%20null%201.mov?dl=0

second video: https://www.dropbox.com/s/b87nms74o861zjv/Pre-comp%203BM%20track%20w%20null%20hand%20fixed.mov?dl=0

1 Like

Can you try moving the anchor point for the head down and then linking the transform data to the anchor point? Otherwise, send me the shot with the AE file and footage and I will take a look. You can email me at maryp at borisfx.com

Thank you so much for your help Mary! I got it working by fiddling w anchor points and other stuff you suggested. Honestly for some shots the AE tracker works better but mocha works great for others.

1 Like