Tracking data keeps disappearing - Mistika OFX

Hey team,
I’ve used Mocha lots with AFX and I’m trying to use it now as an OFX plugin for Mistika Boutique… But I keep doing a track, hit save and go back to Mistika and it doesn’t seem like the tracking data is saving anywhere… When I open it back up in Mocha the tracking layer is there but no tracking data. Anyone used Mocha with Mistika who could tell me if that’s meant to happen and I just need to render it out or something? It’s getting pretty annoying now!

By “AFX” did you mean Adobe After Effects or something else?

The best way to tackle this, is if you could fill a support ticket and provide the full info about your system and build versions for both Mocha & Mistika. That way our QA can try to reproduce that and see if there’s an issue

Here’s the direct link

Hi Dan

Have you exported the data out of Mocha Pro?

Here’s a direct link to the Mistika section:

Hmmmmm nah I was just hitting the save button. In After Effects I would normally send it to Mocha, do the track. Press save. And then the tracking data is always there each time I bring it back up in Mocha. Does it not save the data when you hit that from Mistika?

No, it’s a different workflow for Mistika. You have to export it from inside Mocha Pro.

You can see me show it on an old livestream here : Finishing and VFX Workflows in Mistika: Boris FX Live 009 - YouTube

But the manual takes you through the steps.

Let me know how you get on.

Great Information, thank you

Cool thanks @Ben_Brownlee.

I got a weird error message when trying to save the mistika tracking data:

And it seems weird then that under the mocha pro OFX plugin it has module renders and the option to do a render in there if it doesn’t save any of the tracking data through the save button in Mocha? If you can only pull the tracking info back via the file then what are these settings for under module renders?

Based on what I could tell from your video - that export option was more for exporting tracking info if you want to track an object to something or remove something from the frame - maybe stabilisation of normal footage. I’m wanting to use it for reorienting/stabalising 360 footage? As you can see in my loom I do the tracking and reorienting in Mocha incl rendering it out. Save, go back to Mistika. Then when I open Mocha again the shapes are there but the rest of the data is gone.

Atm my workflow is I’m stitching in Mistika (these are 8k files from a qoocam 8k under a drone). Removing the drone in mistika. Then sending it to mocha, doing a couple of tracks. Reorienting to keep the horizon level. Rendering that out and saving it as a file and then reimporting it back into Mistika. Is that the workflow I should be having when trying to stabilise 360 footage? (I’ve tried using the Mistika stabiliser and it isn’t really good enough to level things out properly and keep them super stable hence why I’m doing it in Mocha instead.

That’s weird. We need to test what’s happening here because there is something definitely not right on many levels here.

  1. You can’t export data from the plugin. I wondered if it’s because it’s a long clip and was just hung writing lots of data, but it’s less that 300 frames long. Is that behaviour consistent?

  2. What happens if you hit the Save button before you close Mocha Pro? Does it remember the data? If the plugin isn’t keeping the data then the render inside of Mistika isn’t going to work either, so that bit makes logical sense and points to a problem higher up the chain.

  3. Can you export the rendered file out of Mocha? When you are stabilized, if you go to File > Export Rendered Clip, does that output a file?

Yeah the behaviour is consistent, I’ve tried shorter clips but same issue happens there.

If I hit the save button before closing Mocha then it’s the same thing. The shapes are normally there when I open it back up but none of the tracking data is there.

And yeah I can export the clip and that’s the workflow I’ve been using to get around it, but (to add another issue into the mix) the project I’m working on atm is 8k (7680x3840) so understand it’ll be pretty resource intensive. On some of the shots through I’m maxing out 100% of my ram (128GB) and then it tends to stop rendering. Ordinarily I’d save, close down to offload ram and start again, but at the moment I’m having to quit out and start the track all over again from the beginning which is pretty frustrating with no save.

Today I decided to subscribe to the stand-alone version of Mocha, rendering shots out of Mistika, pulling them into Mocha. Then rendering back out and bringing them back into Mistika. It’s more stable, but it’s just a lot of extra render steps.

Secondary question. Using the standalone version now (which is going much more smoothly), but when trying to create clean plates in the standalone version it only gives me the option of creating tifs. The OFX version were exr files. The exr files are actually easier to work with… Is there any way I can change the format from TIF to EXR on the standalone version for clean plates?

Sorry it took a little time to get back here, but I had to check things with other sources as there are a few things going on. Let’s break it down a bit…

1. Mocha Pro Remove - Any technical reason why the standalone only offers TIF for cleanplates?
This is dependent on both the source clip’s bit depth, and a setting in Preferences.

In preferences it should offer TIF and DPX for Integer formats and TIF or EXR for floating point.

2. Why the Mocha Pro plugin wouldn’t be saving data when it is closed out?
The data is saved to the project. It’s possible that the cache is write protected. We’d need to see the Mocha log. This may be best handled as an official Support ticket as I am unable to reproduce this on my system. All data saved and exported correctly, and the Mocha render in Mistika worked correctly too.

Can you open a ticket and reference back to this forum post please :

3.The Mistika track exporter throws a blank error at the end of export.
This looks like a transient bug. I’ll check with the dev team as I can also reproduce this. The good news is that the tracking data is still written to the file and produces valid data when imported back to Mistika.

Cool cool. I’m travelling atm but I can fire through the log on Friday when I’m back at the computer. I do have that option for float result clip format though and it’s set to exf. The integer one is set to tif though. Sorry for being dumb but whats the difference between integer and float there? Is that just bit depth (ie if the project is 32bit then its float and if it’s 16bit it’s integer? Or something like that?). How do I change the project bit depth?

Is it depth conversion?

Float is 32-bit, integer is 16 and 8-bit.

The project bit depth will be interpret in the plugin by what is being sent via the host.
You can see what is being sent from Mistika by checking here:

Cool thank you. How do I change it in Mocha? I’ve moved away from using the plugin from Mistika because it was causing too much grief and I just need to get the project out. But I export as a prores file in Mistika. Then import it into the standalone Mocha and go from there. Is it that depth conversion setting that sets it as 32-bit?

You can convert it there if you like.
Personally, I’d convert it externally to be sure you know what bit depth you’re in. It’s better to be working end-to-end in the format and bit-depth you need, just so you don’t lose any information.
Mocha is trying to keep things consistent from source to output.