Tracking data not match!


#1

Mocha Pro 5.1.1
NukeX 10.0v2

When copy NukeCornerPin to clipboard, it doesnt match!!
Frame rate and frame offset the same.
I adjusting track in Mocha and it fine, but in Nuke it shakes and not match at all.


#2

Is this in the standalone or the plugin? If it’s the standalone, it’s likely that your settings are not the same between mocha and nuke.


#3

It’s the standalone.
What settings do you mean?


#4

I record video with copy-to-clipboard CornerPin. In Mocha its all smooth. But when you copy CornerPin data to Nuke, image start to shake and not match coordinates.


#5

Maryp, seems like you software have error with CornerPin. When I use Tracker in Nuke and save data like ASCII, then add trackers and import ASCII - coordinates are DIFFERENT! Compare “Nuke CornerPin” and “Nuke ASCII” export method - there are different coordinates, thats why CornerPin method not work correct.


#6

I mean do your clip settings in nuke match the clip settings in Mocha Pro?

When you paste or import your mocha data into the final composite or edit, make sure you are pasting or loading your data in at the first frame of the clip, otherwise your data may not line up.

Project settings such as frame rate, dimensions and pixel aspect ratio must be match between your mocha project and your destination software. Make sure these values match the settings in your compositor or editor and inside of mocha, otherwise your tracking data will not match when you export it.


#7

Yes, it was in my 1st post - “Frame rate and frame offset the same”

Yes, I did it in video too.

It’s not about the settings. ASCII work fine, error with CornerPin - same footage/settings - different results. Watch the video please and check it in your side.


#8

Hi there, I have encountered the same issue as yours many times in my Adobe AE while importing data from mocha…

The solution to this issue (after analysing your video) is to import the tracked data to the Second frame of the footage instead of the First frame. If you still get the error, try to import it to the frame before the First frame… Either one of these will definitely work.

I used to believe I’m going wrong somewhere and thought I had to remove a shot due to this error… later on I found this solution myself and realised Mocha is amazing!


#9

OK, we are going to see if we can repeat this on our end.


#10

From what I can see In the video, your mocha first frame offset is zero. In nuke, the timeline first frame is 1. This would be causing the problem. Check your dopesheet to see if the keyframes are before the first set frame in Nuke.

If you change your first frame offset to 1 in mocha, you should be able to re-export the corner pin to the right keyframes.