Tracking Data to Text layer?

I have tracked a picture-frame in Mocha, and need to put on some text in After Effects on top of the frame. The tracking works perfect using Mochaimporter to import the tracking data into After Effects.
I then need to select a layer/precomp to paste the tracking data onto in After Effects, but when I do this, my whole comp scales way up so the text I have in my precomp is getting blurry because of the scale. I have tried to enable the “Continuously Rasterize/Collapse Transformations” button, but this messes up the CC Power Pin effect.
In other words : How would you apply the tracking data to a text layer or precomp in After Effects, without blurring/pixelizing the text?
Thanks so much.

Hi Rick,
Which version of mocha are you using?

Hi Rick,

Which version of mocha are you using?

Ok, yes, this is a problem specifically with the motion blur export in that version of mocha.
What happens is that the corner pin is set to 100% scale at frame 1, so if your surface scales up it can only get larger.
We have fixed this in a later version in our standalone software, but for the time being you will have to use the non-motion blurred version of the export and use CC motion blur instead if you are using the current Adobe bundled version.

Ok, yes, this is a problem specifically with the motion blur export in that version of mocha.

What happens is that the corner pin is set to 100% scale at frame 1, so if your surface scales up it can only get larger.

We have fixed this in a later version in our standalone software, but for the time being you will have to use the non-motion blurred version of the export and use CC motion blur instead if you are using the current Adobe bundled version.

Hi Martin.

I’m using Version 2.3.0 build 3509.

I have tracked a picture-frame in Mocha, and need to put on some text in After Effects on top of the frame. The tracking works perfect using Mochaimporter to import the tracking data into After Effects.

I then need to select a layer/precomp to paste the tracking data onto in After Effects, but when I do this, my whole comp scales way up so the text I have in my precomp is getting blurry because of the scale. I have tried to enable the “Continuously Rasterize/Collapse Transformations” button, but this messes up the CC Power Pin effect.

In other words : How would you apply the tracking data to a text layer or precomp in After Effects, without blurring/pixelizing the text?

Thanks so much.

The problem was apparently that I used the motionblur export option from Mocha.
When I disabled that, the composition wasn’t scaled up, so ended up using that.
I would have preferred to use the motion blur option, but I went for a clear readable text instead of the motion blur, so this can be used as a workaround, but would still love to find the reason for the comp. scaling in AE.

The problem was apparently that I used the motionblur export option from Mocha.

When I disabled that, the composition wasn’t scaled up, so ended up using that.

I would have preferred to use the motion blur option, but I went for a clear readable text instead of the motion blur, so this can be used as a workaround, but would still love to find the reason for the comp. scaling in AE.

Hi Martin.
I’m using Version 2.3.0 build 3509.

Just to clarify i have two screenshots, showing the problem:

http://img576.imageshack.us/img576/2369/motionblur.jpg

When using the motion blur export , the pictureframe scales up when it’s closer to the camera, but it seems like it starts at 100% when the frame is far away from the camera, and then scales beyond 100% when the pictureframe comes closer and closer.

This doesn’t happen when I export without the motion blur option.

Just to clarify i have two screenshots, showing the problem:
http://img576.imageshack.us/img576/2369/motionblur.jpg

When using the motion blur export , the pictureframe scales up when it’s closer to the camera, but it seems like it starts at 100% when the frame is far away from the camera, and then scales beyond 100% when the pictureframe comes closer and closer.
This doesn’t happen when I export without the motion blur option.