Tracking is perfect in Mocha but slips away in AE

I have a shot where the actor is walking toward a wall and the camera is following him. I am planning to place a few elements on the wall. I can track the wall perfectly but the track slips away toward the end of the shot in AE.
The aspect ratio, frame rate and the frame numbers match in both apps.
This is what i do

  1. Select the wall area
  2. Select the actor and manually adjust the spline to subtract him from the wall
  3. Select 90 and perspective as well
  4. Track. (which is perfect)
  5. Alignt the surface to the wall using the grid
  6. Align with Align surface
  7. Test in Mocha with a logo or grid (again the track is perfect and the logo sticks to the wall)
  8. Export tracking data using transform
    in AE
  9. Copy the data to a null object and change the anchor to zero
  10. Place the elements on the wall and pre-compose with the same dimensions
  11. Parent the comp to the null object
    Track slips away toward the end. It seems that its more a scaling problem.
    Thanks for your help.

Thanks Mary. I tried the corner pin and it looks much better. So what is the problem?
How can I use the corner pin data where there is no corner on the surface?

OK. Its V2.2.0. That explains the problem. I have had this problem on almost all the shots that I have worked on. Can you please direct me to a page where it has the instruction on how to upgrade to latest version of Mocha AE?
Thanks

The track works fine when I use corner pin export but it doesn’t work with transform. Am I doing something wrong?

Is there any tutorials on the work around (using the corner pin data instead of transform)? I know how to use the corner pin where there are four corners on the surface.

Hi Ash,
Do just double check the settings on your footage interpretation and your AE comps and make sure the settings are the same (especially the FPS) as they are in mocha.
Also, can you please try using the “mocha corner pin export only” and see if that solves your issue?
Cheers,
Mary

Hi Ash,
I am sorry, I’m not sure what you are asking me. Does the import work fine now and you’re wondering why or is it still not where you want it to be?
Cheers,
Mary

What version of the software are you using? It might be due to older versions of our software having a scaling issue on import to AE. We fixed the issue in 2.5.3, but the old workaround was to use the “corner pin only” export.
You should be able to use the corner pin transform fine if it’s working. Just adjust your object to work with the corner pin transform in AE.
Cheers,
Mary

If it’s the version that comes with AE, you’ll need to upgrade to our newest software here: http://webshop.imagineersystems.com/index.php?dispatch=categories.view&category_id=214
If it’s not, and you’ve already upgraded to our version that does not come with AE, you should just be able to download the new version here: Boris FX | Downloads
Depending on what type of work you’re doing though, you may want to think about upgrading to mocha Pro, which can be found here: http://webshop.imagineersystems.com/index.php?dispatch=categories.view&category_id=228
The differences between mocha AE and mocha Pro are listed here: Boris FX | Mocha Pro 2022.5
But the main difference between AE and Pro is the ability to render mattes and inserts with motion blur, lens correction, stabilization with auto back-fill, rig removal and clean plate tools (the remove tool), and the insert tool for speeding up the screen replacement process. They both still have the same great tracker and corner pin/roto tools you’re used to.
Let me know if you have any more questions, or contact our sales team at sales@imagieersystems.com!
Cheers!
Mary