Tracking problems

I’m trying out Mocha Pro trial to see if it’s suitable for an upcoming aerial stereo video production which will involve lots of tracking & objects remove scenes.

I’ve watched various tutorial and started trying out on Mocha tracking function but doesn’t seem to be able to get a good track, the planar surface always drift.

3 of the videos I’m testing on:

1st & 2nd videos - Drone flying on top of a giant baby statue

https://www.youtube.com/watch?v=Ypg8bDGU4GE
https://www.youtube.com/watch?v=nHw3UlWWmvc

  • Trying to do a background track to test out the Remove module to remove the baby statue. But can’t seem to get a good track.

  • I set my planar surface on the white path behind the statue to check drifting. The planar surface always drift as the perspective become closer.

3rd video - Drone fly on top of housing estate

https://www.youtube.com/watch?v=O1j08oGazNo

I can’t seem to even get a good track on a simple scene like this with many planar features

  • Trying to track the small white rooftop on the center

  • I set my planar surface on the 4 corner of the rooftop to check drifting. The top edge of the planar surface always drift as the perspective become closer.

Greatly appreciated if anyone can provide me any advice & guidance?

Hi there,

Try tracking from the areas of most detail to the areas of least detail and avoid any shadows that cross the plane. If you track from where the plane is largest in frame, least blurry, and most parallel to the camera to areas where you’re zoomed out, you will get much better results.

Cheers,
Mary

Hi Mary,

Manage to figured out the technique to produce a decent track for most of the footages I’m trying out on.

I’m trying out camera solve now but keep encountering the “nulls may have low accuracy” warning while trying to export to AE, even for solve with 99% quality. Mostly all the center nulls are distorted in AE, any advice?

Also for drone shots that are quite difficult to track or find non-coplanar for 3D solve in the scene, how should I handle those?
Such as the Drone flying on top of a giant baby statue I posted above, I can tack the ground for the first planar but which other area should I track for non-coplanar?

If you’re encountering the “low accuracy” error, it means the track isn’t as good as we’d like to do a solve with. Try using adjust track to make sure the track is rock solid and make the surface tools smaller.

When you can’t find non-coplanar planes you unfortunately can’t get a solve with the Mocha camera solver. Try another 3D tracker for those shots. You can use the insert inside mocha to render out non-motion blurred textures to help other camera trackers get an otherwise impossible solve though.

I’d try the ground and the top of the baby statue. They’re non-co-planar.

Hi Mary,

What’s is workflow for solving stereo scenes & export to AE or Maya for compositing of 3D elements into live footages?

I presume Mocha only export single Left/Right tracking data to AE for 2D elements, there are no 3D camera?

What about Maya, am I only able to export single Left/Right camera & nulls, there are no stereo camera?
I tried Export all views, but the FBX is empty.

Currently Mocha Pro does not do a stereo 3D solve. While Mocha Pro has the 3D solver module, I do not recommend looking at it to “replace” dedicated 3D application programs such as SynthEyes or PFTrack.

The solve is intended as an alternative planar approach to getting a 3D solve. This can sometimes be much faster than a dedicated 3D tracker and can also assist when 3D trackers fail (on occluded or out of focus clips).

Generally the 2.5D planar tracking, roto-masking, object removal and stabilization modules will all work in stereo workflow. Hope this helps.

But the 3D solver module able to do stereo 3D solve for 3D program such as Maya?

I tested on a few stereo clips with Large Parallax but only able to export single Left or Right camera. If I tried “Export all views”, the FBX is empty.

When I switch to Small Parallax or Auto, sometime I am able to “Export all views” successfully and able to open the stereo camera in Maya. But Small Parallax usually take very long, I’m testing on 100frames and the solve could took 15-30min, mostly stuck at 99%. Is it normal?