Unknown I/O error when attempting to save mocha mask in AE

I keep getting an Unknown I/O error that prevents me from saving and locks up my renderer when I attempt to save a group of mocha masks that have been brought into AE as .txt (scale, position, rotation.) It’s a school of fish that have been roto’d and for whatever reason, when I reach a certain number of these fish from the group I get the I/O error.

 

I have ample space on my hard drive and have tried purging my cache and saving the project elsewhere, so I’m almost certain it’s something problematic within mocha that’s causing this issue in particular with these masks since I’m able to work on my other projects fine and even use other masks from that project aside from the fish one with no issues.

 

Anyone have any experience with this/want more info?

 

 

Hi, we’d love more info to try and track this down. What is the error you are getting?

Exactly that. It just says “Unkown I/O error” when I try to use masks from a certain group after a point, which prevents me from saving my work or rendering.

Theres another mask on the same project for like a turtle in an aquarium that I’ve been able to render, but when I start messing with this group of fish that I did in an early part of the video on the same project, they all give me the I/O error when they come into after effects.

I’ve tried it in multiple project files and it’s always the fish that make it break. Maybe something is corrupted?

Are you using perspective when you track the fish? It could be that the track is becoming corrupt. If you open mocha and look at the fish, turn on the surface tool, see if the surface tool stays on them for the entire shot. If not, and the surface tool disappears, then you have a bad track and that could be leading to this error. Can you check that?

Sorry for the late response.

 

None of the groups of fish have perspective tracked in, though some have shear. The surface tool shows some weird shapes at some points, but they generally track along with the shape data.

 

However, there are segments where I deleted tracked keyframes in the dopesheet because they made the movement of the fish shape look too janky, so the surface just stays where it is when that occurs and then pretty much follows when the tracking begins again, Though it’s hard to tell because the tracked shapes are pretty small.

OK, if you can see the surface tool the whole time, your tack is probably correct. How small are your fish shapes? Are they larger than 20x20 pixels?

Yes they are generally larger but some shrink to nothing though are pixelated before this shrinking occurs.

Can you email me some screenshots? MaryP@imagineersystems.com