Upper layer still active when not visible


#1

Hey all, was hoping someone could help me with a quick problem. Using the mocha pro after effects plugin and the top layer is occluding my track even when it is not visible. Is this normal? I thought for sure that when you turned off visibility on the layer it would no longer process. Can anyone tell me how to not have a layer process when not visible?

Cheers,

Nathan


#2

Hi Nathan,

That is correct: Non-visible layers are still active and contribute to the track. If you want to have it not contribute you have two options:

  1. Drag the layer below the track layer you want
  2. Deactivate the layer by right-clicking and choosing “deactivate on current frame” (this is keyframed, so be careful!)

If you’d prefer it NOT to work like this, let us know. :slight_smile:


#3

Awesome thanks for the info! Personally, it would make more sense to me to not include nonvisible layers in the track, but I am also happy to work around it!