Using Exported Silhouette Shapes in Nuke - Best Practices

So, after rotoscoping hundred of shapes in Silhouette, all with motion blur, you export the shapes to Nuke splines. Once imported into Nuke, you are wondering why the Alpha channel looks different than it did in Silhouette. This is because the default Nuke Viewer settings apply a LUT to not only the RGB channels, but the Alpha channel as well.

To ensure that the Alpha channel displays the same in Nuke as it did in Silhouette, there is a specific Nuke > Viewer control that needs to be enabled.

  • Select the Nuke > Viewer node, right-click in the Viewer and choose Viewer settings to open them.
  • Enable “apply LUT to color channels only”
    viewer-settings
    (Note: You can make this a default Viewer setting in the Nuke preferences.)
    The Alpha channel in Nuke will now match Silhouette.

Here’s an example of the difference you will see when the Viewer LUT is applied to all four channels instead of just RGB. Note how the Nuke example expands the soft areas of the matte.
sfx-alpha nuke-alpha
diff-alpha

2 Likes

That’s lovely!

Hi
when I render png in silhouette 2021.5 the png edges get dots


can you please tell how to fix this

@dineshrajkumar99
What is you Silhouette session bit depth?

Have you tried rendering to the other formats that support alpha like SGI or TIFF? Do you still see the issue after doing so?

I am facing this issue only on png format render
The rest of the formats is good

Bit depth is float 16

OK, I can reproduce this if there is blur or motion blur on the shape. Does your shape have blur or motion blur?

Motion blur

I have filed an issue for this to be fixed. Thanks for pointing it out.

1 Like