Viewport lag [Slow moving control points]

Hi,

I have two layers, “Track” and “Mask”. “Mask layer” is linked to track “Track layer”.
Viewport panning and zooming is very smooth, But when I chose “Mask layer”, viewport is very laggy. Moveing points of “Mask layer” is laggy.

Is this normal?

MochaPro OFX 2020.5.1 / Fusion Studio v16.2.3 / Windows 10 / Quadro P4000 and Geforce 1080 Ti Studio Driver 442.92

I try to update driver 451.48. But nothing has changed.

I found that mouse operation is fine!

This seems to be a issue with Wacom’s Tablet. I use Intuos 5 Touch (6.3.40-2)

All viewport operation is laggy compared to mouse operation.

Thank you, we have seen some delay with wacom tablets and are working on a solution. Unfortunately this is a known bug. I can see if @martinb has an update on our progress in this issue though.

Try going to the Mocha Preferences and turning OFF tablet pressure:

Then reboot fusion.

You only need tablet pressure if you are using the area brush, so turning off the tablet pressure option reverts the wacom drivers in Mocha back to a version that shouldn’t lag.

Yes, I read release notes. Much better.

Thank you.

1 Like

I’ve edited the title of your post slightly just in case people are searching for the same solution.

I am having terrible lag using Mocha Pro (Mocha AE works fine).

I am do not have Wacom tablet and have disabled the pressure sensitivity and it does not help…

I am on AE 17.1 (in 17.1.1 both Mocha AE and Pro are unusable due to lag). I have tried disabling GPU support and that didn’t change performance…

Please advise!

Thanks in advance!

Hi @ilyav ,

I tried contacting you via aescripts support but it must have got lost in the in between.
Can you send me directly the log from the Mocha help menu?

  1. Open the Mocha GUI
  2. Go to the Help Menu
  3. Select “View Log”
  4. Send us the full file that opens

You can send it directly to martinb [at] borisfx.com

I’m having the lag issues with the wacom tablet, but if I update to the latest driver, I get offset issues (I click on a spot and it selects something 25? pixels to the left. I have to dump out of the plugin, and sometimes fusion 16 altogether to get it to work. I’ve downgraded the driver, and applied your fix, but still have the lag issue (the offset select is fixed).

Can you give us some more specifics @brmvfx?
Version of host and Mocha etc?

Version information is useful as we may have already fixed the problem or have a workaround.

Sorry about that. I’m using Fusion Studio 16.2.3 build 7 and mocha OFX 2020.5/v7.5.1 build 127.g9540376abd59

thanks,

bruce

@brmvfx Are you using a tablet?
If so, can you try going to your Preferences and turning OFF tablet pressure in the System tab, then restarting Fusion?

Use tablet pressure is off. IIRC, I had this on then read somewhere to switch it off and I did. The problem “seemed” to go away, but then continued doing it.

Thanks

Hmmm… are you using the Area Brush or just doing general roto?

The new version should stop the problem. Can I see your GPU settings in Mocha preferences?

Just general roto. Also seems to come and go (sometimes it happens, sometimes it doesn’t, sometimes it starts after it hasn’t), haven’t been able to pinpoint why (keystrokes, mouse movements, window movements (full screen/windowed), etc), or why/how it stops or starts yet.

Thanks

Try reducing your ‘Amount of texture RAM to reserve’ down to about 1024. You probably don’t need that amount of video RAM reserved. You’ll need to restart Fusion to restart the plugin environment to see this take effect.

Another (maybe helpful to know) thing about this, is that the selection box is slow too. I click and drag and it has to catch up with the stylus (I’m already done drawing by the time the box catches up) It seems to happen when I first enter Mocha Pro.

It seems to have more issues the more I’m in Mocha and moving the timeline, creating a keyframe, moving the timeline, etc. Maybe memory issue?

I changed the memory, and still has the issue. Is this update coming shortly?

thanks

do have an idea when this update that fixes this issue is coming out?

thanks,

bruce

Any luck on the update?

thanks

Yes I got it thank you