Weird corner pin problem

I’m having a strange corner pin problem.

I have a shot where I’m tracking a screen onto a phone. It’s quite a difficult shot and I’m needing to do a lot of manual tracking in the Adjust Track module. But when I paste the date to AE as a corner pin effect, only a couple frames. The rest have keyframes but all 4 corner points are in the left bottom corner of the frame.

Do you know what could be happening?


Is the size of the screen you are pasting your data on to the same size as your footage? If not, you will have to adjust some settings in your export or on your screen. Boris FX | Align Surface and Mismatched Resolutions

Please let me know if you have any more questions and I will be happy to help you.


Yes it is.

It works for a couple frames, then goes all wonky.


OK, that sounds like a frame rate mismatch or a bad track.When you paste or import your mocha data into the final composite or edit, make sure you are pasting or loading your data in at the first frame of the clip, otherwise your data will not line up.

Project settings such as frame rate, dimensions and pixel aspect ratio must be match between your mocha project and your destination software. Make sure these values match the settings in your compositor or editor and inside of mocha, otherwise your tracking data will not match when you export it.

If your are using Adobe After Effects, the target layer you are pasting data to should also be the same size as your AE composition. A good After Effects troubleshooting tip: create a new solid that is the same size as your composition. Paste your track or roto shape data to this layer. If it does not line up, the issue is mostly likely a project mismatch.

Please let me know if that works for you. Make sure you check your footage and not just your comp settings, if your footage is 23.976 and your comp settings are 24 frames per second, and your mocha project is 23.976 then your data won’t line up.

I think I got it figured out. I wasn’t setting the planer surface before I moved over to the adjust track module.

Thanks for your help!