Why are my beziers constantly shifting?

Hey all

I’m currently rotoscoping a piece of paper and I’ve restarted the process so many times at this point. I have outlined it, but randomly, the points just seem to lose track occasionally. I had to split these into several layers only doing two frames at a time and just turning them off just to circumvent this, but even this eventually fails - randomly.

I have a saved project file, but reopening it will most likely mess with the bezier points for some reason.

Image example. I have open a saved project file with the rotoscope I want, I then exported these shapes into a clean file. The re-export is not correct at some points and is representative of what could possibly happen when I just simply re-open the saved file with the presume final rotoscope:

There is seemingly no tracking on the layer. I have tried different layers. The final project literally looks as it should until re-opening.

Rexporting the final project as an EXR into Nuke also lends the same issue. Here are some comparison images:

(Ignoring the slipping on the left side of the piece of paper, I have roto’d the entire of body and that’s intentional - the slipping is an issue on the right side):

Specifically, I noticed it always started slipping towards the middle. The start and end frames never changed.

Image 1 = Silhouette [As it should appear]
Image 2 - Re-exported as shape in SIL (error)
Image 3 - Re-exported as EXR in Nuke (error)



Are you saying that the project looks correct until you close Silhouette and reopen it?

How are you exporting the shapes?

What tracker are you using?

Can you send a screenshot showing the tracked layer and shapes in the Timeline as well as your Object List?

Is the frame range exactly the same as in Nuke?

It looks like your track might be getting caught up on the pencil?

  • Yes.
  • Silhouette export as ‘Silhouette Shapes’
  • I was doing it manually. No tracking.

I believe the frame range is exactly the same. It’s just confusing as to why the positioning of the shapes resets upon opening. I have since added more to the scene and none of them have lost track.

I tried splitting everything into separate layers as a way of possibly getting the layers to function properly so the screenshots are quite messy. That worked until reopening the file.


I believe I did it all manually though, which is what’s confusing me. Though the errored frames seem consistent (usually in the middle section of the footage).

Tried doing it in a clean file - and the issue still persists? No tracking data, just manual input. But saving and exiting, some frames just haven’t saved their position?

Is it a issue with the frame starting at 2? I’m very confused by this issue now that I have started with a clean slate. Tried twice and got the issue both times.

Okay it’s not just beziers anymore. I’ve manually tracked this pencil two times and it’s lost track once reopening the scene both times.

Do I have some sort of setting on? I’m just very confused as to why Silhouette would just not remember what I did.

I’m doing it manually so I’m not sure what I’m doing wrong.

Can you record your screen while starting from scratch to demonstrate the problem? Hopefully, this will help determine what the problem is. The only thing that could cause this is closing Silhouette without saving the project.


Not just beziers, just random shapes in this project file? Unsure about why, very frustrating. Waiting extended period before closing after its saved doesn’t change the outcome either FYI.

Sorry for the duplicate posts, didn’t edit some information in the original recording.

The 2nd frame seems to be consistently ‘messed up’, but the other frames remain fine.

Can you send me a download link to the project and media so I can take a look?

Not sure what is going on. It works for me.