Why does the tracking in Mocha look so smooth but is jumpy or go off mark when export

I must be doing something wrong.
I tracked a hair/head wound area using the tracker in Mocha and it looks absolutely perfect in the pre-render with logo insertions and all that. The track is clean, no jerk whatsoever, a great product for sure. But when I put the tracking data onto AE (tried cornerpin, red giant warp cornerpin, even tried to use transform data on a stabilized layer - goes off the mark) it doesn’t look anything like the render in Mocha. Could someone tell me how I can get my track to look exactly like it did in Mocha? Oh, and the footage doesn’t even have much movement, just some slight head tilt. It’s literally like the easiest footage I had to work with, and yet here I am, getting pummeled by this one process. Any help/explanation greatly appreciated!

I must be doing something wrong.

I tracked a hair/head wound area using the tracker in Mocha and it looks absolutely perfect in the pre-render with logo insertions and all that. The track is clean, no jerk whatsoever, a great product for sure. But when I put the tracking data onto AE (tried cornerpin, red giant warp cornerpin, even tried to use transform data on a stabilized layer - goes off the mark) it doesn’t look anything like the render in Mocha. Could someone tell me how I can get my track to look exactly like it did in Mocha? Oh, and the footage doesn’t even have much movement, just some slight head tilt. It’s literally like the easiest footage I had to work with, and yet here I am, getting pummeled by this one process. Any help/explanation greatly appreciated!

Thanks for the response. Now that I think about it the framerate between the track data is off by 1 frame (track data is 29.7 and the clip is 30.1) not much difference so ignore it and just went with the track data. Do you think that is the primary reason? The layer I’m placing over is a png file (wound) and towards the end it bobbles slightly up and down, while it’s prestine on Mocha. What cornerpin option do you suggest in this situation?

Thanks for the response. Now that I think about it the framerate between the track data is off by 1 frame (track data is 29.7 and the clip is 30.1) not much difference so ignore it and just went with the track data. Do you think that is the primary reason? The layer I’m placing over is a png file (wound) and towards the end it bobbles slightly up and down, while it’s prestine on Mocha. What cornerpin option do you suggest in this situation?

Got it. Thank you.

Got it. Thank you.

Here’s a quick checklist:

  • Is the frame rate the same in both applications?
  • Is the aspect ratio the same in both applications?
  • Is your frame offset the same?
  • Is the layer you are inserting a different dimension to the original footage in AE?

Your frame rate has to match perfectly for an accurate application of the tracking data, so you will either need to adjust it in the mocha clip tab to match your AE file, or adjust the AE file to match the mocha data. 29.97 sounds more accurate than 30.1, but I don’t know what you are using.
Is the head wound png file a different size compared to the footage? If so you will need to change it to match by either precomping the layer and fitting it to the dimensions of the precomp, or using align surface.
Check the documentation here (note online docs are for V3 and up, but this section is still relevant to versions below 3):

Here’s a quick checklist:

  • Is the frame rate the same in both applications?
  • Is the aspect ratio the same in both applications?
  • Is your frame offset the same?
  • Is the layer you are inserting a different dimension to the original footage in AE?

Your frame rate has to match perfectly for an accurate application of the tracking data, so you will either need to adjust it in the mocha clip tab to match your AE file, or adjust the AE file to match the mocha data. 29.97 sounds more accurate than 30.1, but I don’t know what you are using.

Is the head wound png file a different size compared to the footage? If so you will need to change it to match by either precomping the layer and fitting it to the dimensions of the precomp, or using align surface.

Check the documentation here (note online docs are for V3 and up, but this section is still relevant to versions below 3):