Why legacy software is required to run the unifi controller?

Is the unifi controller and line of product EOL ?

Like, you cannot install the unifi package without hacking your fresh debian installation to force it to install legacy software like java8 and mangodb 3.4.