Wow versioning is totally messed up

I have been roto-ing an interlaced shot (an issue unto itself) and am using Mocha 1.0 since the upgrade to 1.2 seems to shift my fields slightly (enough that the roto looks off by a field or so).

It has been crashing like crazy on my Intel iMac but I have it autosave every 5 minutes and keep 3 versions. It crashed so I opened my newest save and kept working. Partway through I realized that the latest version is actually super old but has been saved as the newest one, so a huge chunk of the work I did isn’t there, yet I’ve been working on new roto work and have to just chuck it and open up different autosaves until I can find a recent enough version to not lose an hour of work. What is going on? The latest version should not be the same as a version hours ago, especially when I compulsively save all the time. Mocha saves me a lot of work but this has really cost me time. Is this a known bug?

hi everyone i also experienced all of mochas problems like that one you experienced. Working with mocha, you have to know these steps in mind.

First you have to save as much as different versions of your mocha projects. save it every 10minutes, make it a habit and turn off the auto save in the preferences. Save manually by using save as command. auto save in mocha gets your life in hell if you save big roto projects.

Second, mocha is very unstable in windows xp. I am using 64bit vista and it is running smoothly. one issue of mocha is it’s non multicore capability. Think thrice before using the motion blur, rendering can take forever with this limitation, so unless mocha is multithreaded and 64bit capable then mocha is on top of the food chain.

Third, the GUI view of mocha is in fact very slow, so don’t get shocked when you move both the spline points so slow, this is really a mess that can make your roto job so slow, unless you are working with SD resolutions then speed it just optimal but still not fast. Until there is a new version of mocha that can solve these issues, just be aware.

Fourth, working with mocha is fun. the planar tracking is the only reason why mocha is useful, i don’t know why mocha is not capable of doing very simple tasks like other compositing apps. You can’t copy and paste keyframes, if there is then it is done on a hard way going on the curves editor, you also get errors when you are tracking and your memory is not enough. if you get errors do not save your project. instead kill the mocha process. because if you save it, i’m sure if you have 10 layers of complex roto only one layer can be retrieved. it is a mess for sure. that is why you have to save every second if you can and save different versions also.

Fifth the most important issue i see is i can’t see the actual motion blur in mocha, there is no preview when you apply blurs in your spline, and the worst like when i tested it on a 2k film with only 76frames on full motion blur on you are just wasting time. it takes forever rendering it with motion blur, after it is done rendering at last after 3 hours, the worst is when you playback the rendered clip.hehehe you can see your mattes turning on and off. This is really a mess when working with large resolution in mocha. My solution is to render just parts one by one with motion blur and composite that in fusion to get the full merged motion blurred matte. if you are in hurry better do your manual blurring of the matte in compositing, you can save time instead of waiting hours.

I am just saying these things based on experience after working a year and a half with mocha. Mocha is a nice roto and tracking app. only that it is still needs a lot of improvement to be an industry standard roto tool. It is very unstable. before you work in mocha you have to know mocha. What is the purpose of this powerful tool if it cant even render perfectly, it cant even save securely project files, and the worse, is it is slow on performance and cannot get the job done withoout encountering software bugs. I hope imagineers can address these issues on its next version, i am sure many are experiencing trouble with mocha. thanks. peace.

Mocha can save you time for sure. But mocha is a traitor itself. do not trust it base on the tutorials you have seen. Yeah it may be amazing to see how things done so quickly what you don’t know is mocha wont allow you to do things so quickly. hahaha. Mocha still needs medical care. it crashing too much for the beginner. if you like to work mocha like me and the rest, then you have to be cautious.

Anyone can try enabling motion blur on HD1080p footage. Explore it try to put motion blur on all your moving splines from 0.25-0.32 settings and either spline or track mode. let’s say you are rotoing a full man running then test render it out. Come on see the turning on and off of the mattes and this really sucks mocha. On the bright side mocha’s motion blur feature is very damn cool and it produces accurate motion blurs but what is the purpose of this if it can even render out perfectly and smoothly without bugs. The downside of it is you cant see it in preview when you apply a blur. look at fusion, after effects when you enable the mask motion blur you can see it in real time. Mochas price is too much for the bugs and headaches it can cause. that is the downside of mocha. if you are working with mocha just be careful and be cautious. Losing precious work on big clients are what you should think before starting using mocha, if you thought planar tracking is great yes it is !
but just be careful, if mocha looses stability quickly then all your hard roto work starts again. i have experienced this before. that is why save it every second or the fifth and make a copy of it on different hardrives just to be sure.

I’m up to version 6 now due to all of the project files that have mysteriously reverted to older versions during a crash. During the last crash (a hang while saving), my version 5 with 31 layers of roto had only 1 layer when I reopened it. What is going on?

Hi JP, thanks for getting back to me. I appreciate the support and will try the beta version out next round.

As far as fielding goes, I guess I’m just not quite clear on how it’s handled in Mocha. In After Effects I can either interpret interlaced footage as lower, so in standard def, it remains 29.97 but the field tearing goes away while I work. I can also remove the pulldown and work at 24, selecting different cadences.

In Mocha there are similar interpretation dialogues, but when I select lower field NTSC, it loads every field, so jumping ahead one frame is impossible, you have to go by fields because it doesn’t blend things. The upper fields are basically ignored it seems; the mask can do what it wants in the upper field and doesn’t have to match the footage, but lower is taken into account. I’ve been rotoing one lower field, then pushing the forward arrow twice to skip the upper field and go right to the next lower field. I’m not sure if I’m doing that right. I’ve tried removing the pulldown, but no matter what cadence I choose, there is still some tearing that makes roto on those frames pretty difficult. I have also rendered out the footage with the pulldown removed from After Effects, but there are occasional (though rare) torn fields. I suppose I could deinterlace, and then just render mattes from Mocha (to avoid the quality loss that comes from deinterlacing sometimes). Are an!
y of these approaches correct? In the past rotoing in AE, it’s been slow but I haven’t had fielding issues. Lately most of the work I’ve done in Mocha has been 720p, so I’ve been avoiding broadcast fielding there too and it has worked so well.

I noticed that going from V1 of Mocha to V1.2 of Mocha shifted my fields, so I had to finish the project out in V1. It’s possible only the upper fields were effected, I never did a test render, but my masks were noticeably off in 1.2 (though only by a field or so I think). Any help would be much appreciated; everything’s easier in progressive!

Amen Francis. I experienced some weird artifacts that buzz around when I render luma mattes as well. Turning off autosave will stop some of the headaches, and when Mocha works it is a great thing to witness. It’s just when it starts acting erratically that it can be frustrating. Does anyone from Imagineer have any answers to the interlacing questions posed above? I’d love to hear about how to work interlaced, which so far has been really difficult.

Thanks Ross,
I’ll definitely give that workflow a shot. It seems the best thing to do is do your deinterlace method and then render luma mattes only and apply them to the footage in your compositing program of choice to avoid resolution loss during the deinterlace. Mocha is a great program, don’t get me wrong, roto is just one of those tasks that can be a nightmare if something goes wrong. Hopefully the world will be entirely progressive someday—interlacing is awful. Thank you for your help!

Hi Graham,

I’m really sorry to hear you’ve lost work with Mocha. We’re working on a beta version that solves this issue, you can try it if you like, the files are at:

Windows:
http://www.imagineersystems.com/downloads/mocha/MochaV1.2.1-Beta1.exe

Mac:
http://www.imagineersystems.com/downloads/mocha/MochaV1.2.1-Beta1.dmg

There are variety of improvements in this version. It would be good if you could clarify the field issue you mentioned, so we can try to fix it.

Best regards,

J-P

First you have to save as much as different versions of your mocha projects. save it every 10minutes, make it a habit and turn off the auto save in the preferences. Save manually by using save as command. auto save in mocha gets your life in hell if you save big roto projects.

…you also get errors when you are tracking and your memory is not enough. if you get errors do not save your project. instead kill the mocha process. because if you save it, i’m sure if you have 10 layers of complex roto only one layer can be retrieved. it is a mess for sure. that is why you have to save every second if you can and save different versions also.

Yep… TRUE DAT!!!

This is an issue I have dealt with for some time… only I just found out how to fix it… :slight_smile: hmmm… I need to visit and READ this stuff more often.

Hi there,
I read your post and have a few things to add (and possibly help with). I do think that the newer version (beta build J-P posted should help with some of the crashign and saving issues. Please let us know.

I do agree the way we are working with interlaced footage is not optimal. With some good feedback, hopefully we can address these issues. I just ran a few tests and recommend a few things:

For NTSC field footage on import select deinterlace and select ODD.
This will display your 29.97 frames as 60 fields in correct order. It seems what you are looking for is a way to separate the fields, but display only frames in the timeline. There are other compositing systems that do not do this as well but I will add it as a feature request.

Unfortunately there is no advance “full frame” button or something to allow the advance button or arrows to skip every other. There is a button to display the field label on every frame (found under clip tab and time) but this is not what you want.

Once your footage is deinterlaced, you now have double the frames. If the correct field order is selected, the clip should play smoothly with no jitter.

When tracking, you can select track individual fields if there is very significant motion for a more accurate track.

On export, I found that the render order is incorrect. To get an NTSC clip to render out with proper field dominance, I had to select PAL (even) to match my clips original dominance. Have others found the same thing?

If you can compile some of your wishes for better handling interlaced footage, I can make sure that we add it to our feature request list for future versions. Thanks for your patience and as you seem to have found, while not perfect, mocha can still save very significant time for roto and tracking work.

Best,
Ross

Ross Shain
VP & Prod Specialist
Imagineer Systems