Xclip on linux inconsistency

When using Mocha OFX in Nuke I can not copy a shape or track to the clipboard to paste it into Nuke, but in the Standalone I can copy and paste over to Nuke. Why does it work in one but not the other? Is there an easy way to get the OFX version to work like the Standalone?

Thanks,
Brian

Hi Brian, which version is this?

This was with 6.0.1. I’m trying to upgrade to 6.0.2 now. It seems fine on the standalone but the OFX won’t install with rpm -Uvh. I also tried -Ufvh and -ifvh. They all say Failed dependencies, xclip is needed by MochaOFX. I seem to remember finding a way to force it to install before but I can’t find that now. It seems strange that it lets you copy from standalone to Nuke but not from within the plug-in that is inside Nuke.

Thanks,

Brian

Hi Brian,

That missing xclip dependency is exactly why copy/paste isn’t working. Install it from your distro’s repository and the problem should be solved. The procedure for this varies depending on what Linux distribution you are using. For example in CentOS 7, where xclip is in the EPEL repository, it would be:

sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
sudo yum install xclip

Best regards,

J-P

This machine doesn’t have internet access so I can’t use yum. Also, it’s a flame and Autodesk always warn about adding extra dependencies. I don’t know if this would be a problem but I can’t get it anyway.

I’m curious why copy/paste works from standalone to Nuke but not from Nuke plug-in to Nuke.

Thanks,

Brian

You can download the xclip rpm on another machine and copy it over. For example from:

https://centos.pkgs.org/7/epel-x86_64/xclip-0.12-5.el7.x86_64.rpm.html

We needed to use xclip because we found that using the X11 clipboard directly when running as a plug-in in Nuke could cause the host to hang when the Mocha window was closed. By using xclip to put our data on the clipboard, it looks like it was put there by an external application and everything is happy.

Thanks, I didn’t know how to do that. Adding xclip allowed me to install 6.0.2 OFX plug-in. I can copy and paste now but it still hangs for a really long time. It seems better than 6.0.1 because it seems to only hang when clicking the “Launch Mocha UI” button. It takes about 1 minutes to open. Everything in the UI is frozen while it is opening. It happens to new Mocha nodes and re-opening existing nodes.

Thanks,

Brian

Having the same problem, Flame 20 with Linux 7.6. I installed the xclip, question shouldn’t the installer just run the xclip installer since it needs it anyway. After the install Mocha freezes as described above. Just curious because no other OpenFX hangs the way Mocha does. Contacted Autodesk about this issue and it appears it is a Boris Fx problem not a flame issue.

The XClip dependency is not currently included due to specific packaging licenses and the general desire to keep system-wide dependencies up to the individual system.
We specify the requirements carefully in the release notes as Linux dependencies can be a fickle affair and we want to give system admins full control over it.

Can you give us more details on the issue you’re seeing with Flame on Linux?

As much detail as possible is very helpful! We recommend using the template below:

    Version: The version and build number of Mocha where you found the bug

    Platform: A brief description of your machine

    Description: A description of the problem at the beginning of the thread post

    Steps to reproduce: Steps on how to reproduce the problem

    Expected result: What you expected to happen

    Actual Result: What actually happens

    Regression: Was this problem not present in an older build?

    Additional data: Anything else you can supply, such as an attached project or crash log