zMatte and Color Suppress Option

Hello everyone,

I have blue screen footage that I have pulled a key with using xMatte. I made my adjustments and a final adjustment using the color suppress option in the node. I view the final composite and render out DPX files and everything is fine.

I then take those DPX files into After Effects and when imported there is a yellow tint over the entire image. I tried a combination of different things but no matter what I did it was still yellow. I finally took out the color suppress and reset that to default and it worked fine.

I thought the color suppress option was to fine tune blue and green screen footage.

Not sure what’s making that happen but any help would be greatly appreciated.

Thanks,
Gus

What zMatte output did you render–the left output or the right output? The left output renders a RGBA file that is meant to be composited. Depending on how much color suppression you have used, parts of the uncomposited RGBA may appear yellow when suppressing a blue screen. Once composited, you will not see those yellow areas.

With color suppression enabled in Silhouette and when viewing Output in the Viewer, do you see the yellow cast like you do in After Effects?

No, I only see it in After Effects. It looks correct in Silhouette. Sample of node tree provided.

If you load the rendered file in Nuke and use the same OCIO viewer controls as in Silhouette, does the image look the same in both Silhouette and Nuke?

I tried that and the rendered files when imported in =to Nuke do look yellow. The only place it looks correct is in Silhouette.

Can you send me 1 frame of the fg and 1 of the bg along with your project? You can PM me the attachments.

Will do. Thanks Marco.

Files sent.

Change your Output node > Interpretation from Log to Linear and the Depth from 10 bit to 16 bit. The resulting file will then look correct in Nuke.

Silhouette linearizes log files by default, whether Cineon or DPX. You were rendering linear to log without a conversion.

so if I make those changes in Nuke, it will view correctly? Is it the same for After Effects?

So nothing wrong with the file all this time it was just a conversion thing?

The changes I suggested were in the Silhouette Output node of your project and the files need to be re-rendered. You were rendering using the wrong interpretation and bit depth. It should look like this:
image

Just tried it and of course it WORKED!!! Works both in After Effects and Nuke. Thanks again Marco, your a life saver.